VDI Images with VMware Tools SVGA driver – Warning!

Posted by robd on April 16, 2016
Citrix, vmware

If you are building a Client/Server that is going to be used in a VDI environment don’t install the VMware SVGA WDDM driver as part of the VMware tools install.

 

It can cause issues like Black screens, Users not connecting etc and the first step Citrix get you to perform is to remove them, with XenDesktop this is fairly easy but time consuming with VDI-in-a-Box you can’t…

 

For XenDesktop, If you have installed them you can us the follow these steps to remove the driver:

  • Remove VDA agent(s)
  • Reboot
  • Remove VMware Tools
  • Reboot
  • Install VMware tools (Custom install without SVGA driver)
  • Reboot
  • Install VDA agent(s)
  • Reboot
  • Update the Catalogue

 

For VDI-in-a-Box, If you have installed them you can us the follow these steps to remove the driver:

  • Start again with new image.

 

Notes:

If you already have it installed and it’s not causing any issues you can leave it as is.

If you don’t remove the VDA agent before Uninstall/reinstall VMware tools, the guest will break.

VDI-in-a-Box installs the VDA agents when you import the image, you can’t get them any other way. (confirmed by Citrix Support)

 

Both these links mention VMware 4.1 U1 but Citrix have confirmed it is still affects later versions.

http://support.citrix.com/article/CTX123952

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1011709

Tags: , ,

Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Copy Protected by Chetan's WP-Copyprotect.