Outlook anywhere

Outlook Anywhere Authentication Issue

Posted by robd on December 01, 2016
exchange, exchange 2010 / 1 Comment

Had a  crazy problem recently, a company Contoso.com was using Exchange 2010 (CAS, Hubs and Mailbox servers) with all the latest patches and roll-ups and had users on their domain using Outlook Anywhere perfectly.

The problem was their sub domain SubDomain.Contoso.com is also big company, they have their own Exchange 2010 servers  (CAS, Hubs and Mailbox servers) with all the same patches and roll-ups except they’re “downstream” of Contoso.com.  The problem is all users in SubDomain.Contoso.com couldn’t use Outlook Anyhwere, i.e. RPC proxy redirection wasn’t working:

outlookanywhere

The setup:

rpc-over-https

 

So all in all it was weird, we checked everything, firewall blocks, routing problems etc etc, even https://testconnectivity.microsoft.com/

So finally we logged a call with MS and after some lengthy troubleshooting they found the underlying issue:

https://support.microsoft.com/en-us/kb/2725008,

Although the article relates to Exchange 2010 sp2 RU3 it was still applicable in this scenario (SP3 RU15).

Applying the fix documented in method 2 resolved the issue.

“Disable preferred site enforcement
To resolve this issue, disable preferred site enforcement. To do this, create the following DWORD registry value:

Key:

HKLM\System\CurrentControlSet\Services\MSExchangeRPC\ParametersSystem


Value Name: EnablePreferredSiteEnforcement
Data Type: REG_DWORD
Value: 0”

 

Annoying but at least its fixed.

Tags: , , , ,

Copy Protected by Chetan's WP-Copyprotect.